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Microsoft Excel 2016
Basic Authoring and Testing Guide

Document Formatting

1. Is the file name descriptive, and is the file in .xlsx format?

How to test

Instruction: Look at the filename in Windows Explorer or the title bar in MS Excel. An example
of a descriptive filename is “FundingBudget.xIsx.” The file must be in the “*.xlsx” format for
accessibility testing to be possible.

NOTE: If the document extension is not displayed, open your documents folder in Windows
Explorer, select “View"”>check “File name extensions.”

Figure 1: The Save As dialog window

Save As X
— v P [£l > Libraries > Documents v | | Search Documents P
File name: | FundingBudget. xlsx ~
Save as type; | Excel Workbook (*.xsx) ~
Authors: AED COP Title: Funding
Tags: Add atag Subject:

[]Save Thumbnail
v Browse Folders Tools = Cancel

Test A: Is the file name descriptive and does it identify the document or its purpose? If not, the
document fails this test.

Test B: Is the file in “"Excel Workbook (.xlIsx)” format? If not, the document fails this test.
How to author for accessibility

A descriptive file name identifying the document or its purpose helps everyone (including people
with disabilities) locate, open, and switch between documents. In addition, the document must

be in a “.xIsx” format because these authoring and testing instructions will only work if the file is
in the “.xlsx” file format.

Select “File tab>Save As”

e Save as type: “Excel Workbook (*.xlsx)”
e Save the document with a descriptive file name.
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Text Formatting

2. Are built-in features used to organize content?

How to test

Test A: Does each sheet have a visual and/or logical reading order, left to right then top to
bottom? If not, it fails this test.

Test B: Can the sheet be navigated using the up, down, right or left arrow keys, and does it
match the visual/logical reading order? If not, it fails this test.

How to author for accessibility
To create a worksheet with logical reading order content:

e Start all worksheets in cell Al
e Do not span content over multiple rows or columns.

Figure 2: Example of Excel Worksheet with logical reading order

Al - fi Table 1: Quarterly Funding Proposal

A B C _ D _ E

£ S ——

3 Training l §125 5200 50 5200

4 Office Suppli 575 575 575 $75

5 Print Supplies 55 S50 S50 S50,

3. Are link names descriptive?

How to test

Instruction: Find hyperlinks within a worksheet

Test: Do links have meaningful names that describe their destination, function, and/or purpose
OR are these determinable within context? If not, the document fails this test.

Uniquely Named Link:

www.section508.qgov
Link Determinable within context:

Get My Section 508 Questions Answered
An unclear link name with no context:

click here
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https://section508.gov/508-coordinator-listing

How to author for accessibility

Assistive technology users rely on meaningful names to determine the destination, function, or
purpose of links. For example, multiple “click here” links are confusing to assistive technology
users because the name for each link is the same, while the destinations may be different.

Figure 3: Insert Hyperlink configuration window

o J\[J By - e _ - - $ - 9% » EFFormatasTable - =X Delete -~ el
SLe <o | R - - = = = €= 3= =
e il S el s S e s (B e «0 a0 [5# Cell Styles - ®]Format~ & -
Clipboard &
A3 M Link to: Text to display: | Training ScreenTip..
A [[) : - i A
| P e Look in: Desktop o Q
1 Table 1: Quarte | Exsting File or =
= m Web Page = This PC £ Bookmark...
2 ﬂ Current Folder |  Libraries
Place in This ¥ Network

3| Training Eocument

Browsed Pages

4 Office Supplies

5 Print Supplies

Recent Files

6 | v
E-mail Address z 5 o i

7 Address: https://section308.gov/create/documents ~

8

10 : : : . , :

Naming and creating links:

e To edit the name of a link, select the cell containing the hyperlink. Edit the text in the
Formula Bar.

e To create a hyperlink, select the cell for the hyperlink and either use the Hyperlink button
on the "Insert" ribbon menu or “Ctrl+K" to open the Insert Hyperlink configuration
window. Specify the Text to display and the Address for the link and its destination.
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Object Formatting

4. Is vital information in headers, footers, and watermarks
duplicated in the worksheet?

How to test

Instruction: Look for vital information in headers, footers, and watermarks (e.g. Respond by
X date, CONFIDENTIAL, or Do Not Distribute). Note: Watermarks in Excel are floating objects,
and cannot be made accessible.

Test: Is the vital information duplicated in the first cell of the worksheet? If not, the document
fails this test.

Figure 4: Example of vital information repeated in cell Al of the worksheet

Book1 - Excel

Insert Page Layout Formulas Data Review View Developer Acrobat Q Tell me

"D &% Calibri o PP x K== %- = General - [;'E,Conditional Formatting - Em In
B - $ - % »  [EPFormatasTable~ EXD
Paste S 5 vl = = = &= 3= = e
My BIU-I-D-A-=s=s=E%H" o« 54 Cell Styles - &1 Fe
Clipboard & Font P Alignment G MNumber Styles C
H3 = J
1 2 3 4 5
A B C D E F G

DO NOT DISTRIBUTE

Do Not Distribute /

1

2 Table 1: Quarterly Funding Proposal

5 Item CFY Q1 CFY Q2 CFY a3 CFY Q4

4 Training S 125 | S 200 S - S 200
= 3 Office Supplies S 75 |5 75 S 75 S 75

6 Print Supplies S 50 S 50 S 50 S 50

B | Sheet1 @ .

How to author for accessibility

Assistive technology does not automatically read information in headers, footers, and
watermarks, so you need to duplicate any vital information in cell Al.
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5. Did you use built-in features to create data tables?
How to test

Instruction 1: Select a table ("Home>Editing>Find & Select>Go To"). Select any table listed in
the “Go To” options window. Note: Images of tables will never be listed in the “"Go To” options
window.

Test A: Does a “Table Name” display under the “Table Tools>Design>Properties” group? If not,
the document fails this test

Figure 5: Table Properties group displaying Table Name

H ©- = Funding.xlsx - Excel Table Tools

File Home Insert Pagelayout Formulas Data Review View Developer Acrobat Q Ts

[i#] Summarize with PivotTable D | Header Row [/ First Column
>

Table Name:

QtrlyFundingPro A Remave Duplicates Total Row Last Column
= . Insert  Export Refresh
‘D» Resize Taple | 5= Convert to Range Slicer 2 e | Banded Rows Banded Columns
Tools External Table Data Table Style Options

& ltem

CFY Q4 ks

cryQi Bl crvazB crvaz B
Training 5125 5200 S0 5200

Office Supplies 375 575 575 575

Instruction 2: Place your cursor on the first row and/or column of a table cell and see if the
worksheet has identified the header row and/or column.

Test B: Are “Header Row” and/or “First Column” in the “Table Style Options” group checked? If
not, the document fails this test.

Figure 6: Header Row and First Column checked in the Table Style Options group

H ©- = Funding.xlsx - Excel Table Tools

File Home Insert Pagelayout Formulas Data Rewiew View Developer Acrobat

& 5

= . Insert  Export Refresh
‘B Resize Table  §= Convert to Range Slicer - -

First Column
Last Column

Header Row
Total Row
| Banded Rows

Properties Tools External Table Table Style Options

Table Name: Summarizewith PivotTable

QtrlyFundingPro B+f Remave Duplicates

Banded Columns

A2

cryQi Bl crvyazB crva3 B corvaa B
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Instruction 3: Select a table. If the Ribbon shows “Picture Tools” tab, instead of the “Table
Tools” tab, then the table is an image.

Test C: Is the worksheet free of pictures of tables? If not, the document fails this test.

Figure 7: Image of data table showing “Picture Tools>Format” tab when selected

E o - = Funding.xlsx - Excel Picture Tools

File Home Insert Page layout Formulas Data Review View Developer Acrobat

EE| Corrections >  Ja z - Bring Forward
I . = ‘JJ 3 i o

Color ~ Eg . Send Backward
Remove Quick

Background [z Artistic Effects - 92 ~ Styles - [~ | Bk Selection Pang

Adjust Picture Styles
Picture 2 - F

A

|Training 125 § 200 S
|Office Supplies S 75| 5 75 S 75 |5 75

|Print Supplies S 50 § 50 S 50 5 50

(W=

How to author for accessibility

Assistive technology users need to be able to identify column headers in data tables to
understand the association between table cells and their respective headers.

To create an accessible data table you Select “Insert>Table.”

1. In the create table pane, choose the range of cells for your data table.

2. Check the "My table has headers” checkbox in the create table pane.

3. Choose any cell and hame your table “Table Tools>Design>Table Name.”
4

. Choose the first cell in the header column and/or row, and update the column and/or row
headings with descriptive hames.
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How to test

Figure 8: Image of data table showing “Picture Tools>Format” tab when selected

H &y ~ Funding.xlsx - Excel Picture Tools

File Home Insert Page Layout Formulas Data Review View Developer Acrobat

EE Corrections = [ = Bring Forward & P> 08" .
== sl Color - Ba ‘_’J < - Send Backward
Remove Quick Crop ﬁ 443 3

Background EE Artistic Effects = i ~ Styles - L'_!“n" = EL‘: Selection Pang

Adjust Picture Styles &

Picture 2 M I

|Training
|Office Supplies S 75 5 75| % 75 | § 75
Print Supplies S 501 5 50 $ 50 S 50

LA P (=

6. Do images and other objects have alternative text
How to test

Instruction 1: Examine cells surrounding a non-text element for text describing the object or its
purpose/meaning.

Test A: Does the image/object/shape/chart or other non-text element have descriptive text or is
there an appendix for all non-text elements? If not, the document fails this test.

How to author for accessibility

In Excel images, objects, shapes, charts and other non-text elements cannot be
anchored/embedded in a cell. Screen reader users cannot access the alt-text of floating
elements. Therefore, you must add descriptive text to images and other objects by adding
information in a cell near the object, or list the non-text elements and their descriptions in a
separate appendix.
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Color Formatting

7. Are colors and other visual characteristics that convey
information (such as size, shape, and location) also described
in text?

How to test

Using only color or other visual characteristics to convey meaning will not provide comparable
access to people who are blind, have low vision, or are colorblind.

Instruction: Find where you have used color and/or other visual characteristics to convey
meaning such as green, yellow, red, etc.

Test: Is there text that conveys the meaning of the color or other visual characteristics? If not,
the document fails this test.

How to author for accessibility

The following layout tables describe the progress for three projects using colors to symbolize the
current project status. Adding text in addition to the color provides comparable information to
users of assistive technology and people who are colorblind.

Use text to duplicate the meaning of the color or visual characteristics (such as size, shape, and
location).

Table 1: Examples of a project status table using only color and color with text

Project Status Project Status
Project A - Project A -
Project B Project B At Risk
Project C - Project C “

8. Is the contrast ratio between text and background sufficient?

NOTE: If the document text is black on white background (or close to it), you do not need to
perform this test. This test requires the Colour Contrast Analyser (an external application).

How to test

Execute the Colour Contrast Analyser. Select “Download” (the application can be executed
without downloading it onto your computer). Open the Colour Contrast Analyser. Drag the
“Foreground eyedropper” icon over a sample of your text or image of text. Drag the “Background
eyedropper” icon over a sample of your background color.
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Test: Have you formatted with the correct color contrast ratio? If not, the document fails this
test.

Figure 9: Examples of pass and fail results with the Colour Contrast Analyser

1 Colour Contrast Analyser - W
Options  Image Help
Foreground Background
Colour select Hex Colour select Hex:
I | | I~ [#000000 1 [ J~] [ 2= [srFerre
Result - luminogity
Text Foreground:#000000
v | Pass (AA) Background#FFFFFF
L 1
v | Pass [AAA) The confrast ratio is: 21.0:1

Text passed at Level A4
Large fext Text passed at Level AAA

t at Level A
v[ Pass (A | |imiieiesaivan
v | Pass (AAA) |

[]show conirast result for colour blindness Copy results

E Celour Contrast Analyser — ¢
Options  Image Help
Foreground Background

Colourselect Her DR Ao
(N | [Z7] [#o08050 [ (— 2 L

Result - luminasity

Foreground #00B050

T
x Eail (A& Background #FFFFFF

The contrast ratio 1s: 2.9

e Text failed at Level AA
ol Text failed at Lavel A4

x- Fﬂll {Aﬂ} Large text failed al Level A4

Large text failed at Level A8A
® | Fail (AAA)

] 3how contrast result for colour blindness Copy results
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How to author for accessibility

People who are colorblind or have low vision will have comparable access if there is sufficient
contrast between the text and the background. The contrast standards are:

Table 2: Table with contrast ratios for types and sizes of text

Type or Size of Text Contrast Ratio

Standard text (12 pt regular) 4.5:1

Large Text (14 pt bold or 18 pt regular, 3:1
Incidental text, text overlaid on images, and logotypes Excluded from requirement

Create content with text or images of text that use color or shading with sufficient color contrast.
If the contrast ratio does not pass, then adjust your foreground or background until it does pass.

Table 3: Examples of good and insufficient color contrast ratios

Good Color Contrast Insufficient Color Contrast

White text on

black background
ratio 21:0:1 ratio 3.0:1

Dark green text
on yellow background
ratio 7.6:1 ratio: 2.1:1

Light blue text on
dark blue background
ratio: 10.5:1

white text on
red background
ratio: 6.5:1
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Miscellaneous

9. Are descriptions of embedded audio, video and multimedia files
accurate?

How to test

NOTE: If the document does not contain audio, video, or multimedia files, you do not need to
perform this test.

Instruction: Activate the audio-only, video-only, or multimedia file.

Test A: Is there an accurate and complete text transcript for multimedia files, text description
for audio files, and synchronized caption and/or audio description for video files? If not, the
document fails this test.

How to author for accessibility

If you embed an audio-only, video-only, or multimedia file that contains meaningful information
into your MS Excel Workbook, you must also provide additional information so that individuals
with disabilities have comparable access to the information.

e Audio-only
o Accurate and complete transcript
e Video-only
o Accurate and complete text description
e Multimedia (audio and video)
o Accurate and complete synchronized captions and audio descriptions

10. Did you exclude flashing objects?

How to test

Test: Is the document free of all flashing objects? If not, the document fails this test.

How to author for accessibility

Create your content without using flashing objects. Flashing objects can cause seizures and
should never be used.
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